summaryrefslogtreecommitdiff
path: root/sys-kernel/vtty/vtty-0_p20230917-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/vtty/vtty-0_p20230917-r1.ebuild')
-rw-r--r--sys-kernel/vtty/vtty-0_p20230917-r1.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/sys-kernel/vtty/vtty-0_p20230917-r1.ebuild b/sys-kernel/vtty/vtty-0_p20230917-r1.ebuild
deleted file mode 100644
index a59aa5c..0000000
--- a/sys-kernel/vtty/vtty-0_p20230917-r1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2025 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-inherit linux-mod-r1 udev
-
-DESCRIPTION="Virtual serial port kernel module"
-HOMEPAGE="https://github.com/anszom/vtty"
-COMMIT="49f3fb0ba5f062771d06182d24c2b525e4b67dea"
-SRC_URI="https://github.com/anszom/vtty/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${PN}-${COMMIT}"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="virtual/udev"
-DEPEND="${RDEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/0001-vtty_write-with-size_t-counts-for-v6.6.patch
- "${FILESDIR}"/0002-remove-no_llseek-for-v6.12.patch
-)
-
-src_compile() {
- local modlist=( vtty )
- local modargs=( KDIR="${KV_OUT_DIR}" )
-
- linux-mod-r1_src_compile
-}
-
-src_install() {
- linux-mod-r1_src_install
-
- udev_newrules - 69-vtty.rules <<-EOF
- # do not edit this file, it will be overwritten on update
- #
- KERNEL=="vtmx", SUBSYSTEM=="misc", TAG+="uaccess"
- KERNEL=="ttyV[0-9]*", SUBSYSTEM=="tty", TAG+="uaccess"
- EOF
-}
-
-pkg_postinst() {
- linux-mod-r1_pkg_postinst
- udev_reload
-}
-
-pkg_postrm() {
- udev_reload
-}