summaryrefslogtreecommitdiff
path: root/sys-cluster/kubie/kubie-0.23.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/kubie/kubie-0.23.1.ebuild')
-rw-r--r--sys-cluster/kubie/kubie-0.23.1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/sys-cluster/kubie/kubie-0.23.1.ebuild b/sys-cluster/kubie/kubie-0.23.1.ebuild
new file mode 100644
index 0000000..00bfd9a
--- /dev/null
+++ b/sys-cluster/kubie/kubie-0.23.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CRATES=" "
+inherit cargo shell-completion
+
+DESCRIPTION="A more powerful alternative to kubectx and kubens."
+HOMEPAGE="https://github.com/sbstp/kubie"
+SRC_URI="https://github.com/sbstp/kubie/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://share.terinstock.com/${P}-vendor.tar.xz "
+
+LICENSE="ZLIB"
+# Dependent crate licenses
+LICENSE+=" MIT Apache-2.0 Unicode-DFS-2016 0BSD Apache-2.0-with-LLVM-exceptions"
+LICENSE+=" Boost-1.0 ISC BSD Unlicense MPL-2.0"
+
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND=" sys-cluster/kubectl"
+
+src_unpack() {
+ cargo_src_unpack
+ mkdir "${S}"/{vendor,.cargo} || die
+ ln -s "${WORKDIR}/vendor/"* "${S}"/vendor || die
+ cp "${FILESDIR}"/"${PN}-vendor-config" "${S}"/.cargo/config.toml || die
+}
+
+src_prepare() {
+ default
+ sed -i 's/strip = true/strip = false/' Cargo.toml || die
+}
+
+src_configure() {
+ cargo_gen_config
+ cargo_src_configure --frozen --no-default-features
+}
+
+src_install() {
+ cargo_src_install
+
+ newbashcomp completion/kubie.bash kubie
+ newfishcomp completion/kubie.fish kubie
+}