summaryrefslogtreecommitdiff
path: root/net-proxy/traefik/traefik-3.2.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-proxy/traefik/traefik-3.2.1.ebuild')
-rw-r--r--net-proxy/traefik/traefik-3.2.1.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/net-proxy/traefik/traefik-3.2.1.ebuild b/net-proxy/traefik/traefik-3.2.1.ebuild
deleted file mode 100644
index 6f15079..0000000
--- a/net-proxy/traefik/traefik-3.2.1.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-inherit go-module
-
-DESCRIPTION="The Cloud Native Application Proxy "
-HOMEPAGE="https://traefik.io/"
-BDEPEND=">=dev-lang/go-1.23.0"
-SRC_URI="https://github.com/traefik/traefik/releases/download/v${PV}/${PN}-v${PV}.src.tar.gz -> ${P}.tar.gz"
-SRC_URI+=" https://share.terinstock.com/${P}-vendor.tar.xz"
-
-LICENSE="MIT"
-LICENSE+=" Apache-2.0 BSD ISC MPL-2.0 "
-SLOT="0"
-KEYWORDS="~amd64"
-S="${WORKDIR}"
-
-src_compile() {
- local BUILD_DATE
- BUILD_DATE=$(date -u +%Y-%m-%dT%H:%M:%SZ)
-
- ego generate
- ego build -ldflags="
- -X github.com/traefik/traefik/v3/pkg/version.Version=${PV}
- -X github.com/traefik/traefik/v3/pkg/version.BuildDate=${BUILD_DATE}
- " ./cmd/traefik
-}
-
-src_test() {
- ego test ./...
-}
-
-src_install() {
- dobin traefik
-}