summaryrefslogtreecommitdiff
path: root/net-misc/obligator/obligator-0.3.0_p20240910.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/obligator/obligator-0.3.0_p20240910.ebuild')
-rw-r--r--net-misc/obligator/obligator-0.3.0_p20240910.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-misc/obligator/obligator-0.3.0_p20240910.ebuild b/net-misc/obligator/obligator-0.3.0_p20240910.ebuild
new file mode 100644
index 0000000..d7bf8bc
--- /dev/null
+++ b/net-misc/obligator/obligator-0.3.0_p20240910.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+DESCRIPTION="Simple and opinionated OpenID Connect server designed for self-hosters"
+HOMEPAGE="https://github.com/lastlogin-net/obligator"
+BDEPEND=">=dev-lang/go-1.20"
+COMMIT="54bc6d226904adbbda6a2666a4b635a65e79c01f"
+SRC_URI="https://github.com/lastlogin-net/obligator/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://share.terinstock.com/${P}-vendor.tar.xz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+LICENSE="MIT"
+LICENSE+=" BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_compile() {
+ ego build ./cmd/obligator/
+}
+
+src_test() {
+ ego test ./...
+}
+
+src_install() {
+ dobin obligator
+}