summaryrefslogtreecommitdiff
path: root/dev-vcs/ghq/ghq-1.6.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/ghq/ghq-1.6.2.ebuild')
-rw-r--r--dev-vcs/ghq/ghq-1.6.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-vcs/ghq/ghq-1.6.2.ebuild b/dev-vcs/ghq/ghq-1.6.2.ebuild
new file mode 100644
index 0000000..8c62f41
--- /dev/null
+++ b/dev-vcs/ghq/ghq-1.6.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+DESCRIPTION="Remote repository management made easy"
+HOMEPAGE="https://github.com/x-motemen/ghq"
+BDEPEND=">=dev-lang/go-1.22.5"
+SRC_URI="https://github.com/x-motemen/ghq/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://share.terinstock.com/${P}-vendor.tar.xz"
+
+LICENSE="MIT"
+LICENSE+=" BSD-2 BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_compile() {
+ ego build .
+}
+
+src_test() {
+ ego test ./...
+}
+
+src_install() {
+ dobin ghq
+}