summaryrefslogtreecommitdiff
path: root/dev-python/plover-python-dictionary/plover-python-dictionary-1.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/plover-python-dictionary/plover-python-dictionary-1.1.0.ebuild')
-rw-r--r--dev-python/plover-python-dictionary/plover-python-dictionary-1.1.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/plover-python-dictionary/plover-python-dictionary-1.1.0.ebuild b/dev-python/plover-python-dictionary/plover-python-dictionary-1.1.0.ebuild
new file mode 100644
index 0000000..55a8939
--- /dev/null
+++ b/dev-python/plover-python-dictionary/plover-python-dictionary-1.1.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python dictionaries support for Plover."
+HOMEPAGE="https://github.com/benoit-pierre/plover_python_dictionary"
+
+RDEPENDS="
+ app-text/plover[${PYTHON_USEDEP}]
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest