summaryrefslogtreecommitdiff
path: root/dev-go/gotestsum/gotestsum-1.12.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-go/gotestsum/gotestsum-1.12.0.ebuild')
-rw-r--r--dev-go/gotestsum/gotestsum-1.12.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-go/gotestsum/gotestsum-1.12.0.ebuild b/dev-go/gotestsum/gotestsum-1.12.0.ebuild
new file mode 100644
index 0000000..fa9f75b
--- /dev/null
+++ b/dev-go/gotestsum/gotestsum-1.12.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+DESCRIPTION="'go test' runner with output optimized for humans"
+HOMEPAGE="https://github.com/gotestyourself/gotestsum"
+SRC_URI="https://github.com/gotestyourself/gotestsum/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://share.terinstock.com/${P}-deps.tar.xz "
+
+LICENSE="Apache-2.0"
+BDEPEND=">=dev-lang/go-1.13"
+
+SLOT="0"
+KEYWORDS="~amd64"
+# TODO: fix test failure with deps tarball
+RESTRICT+=" test"
+
+src_compile() {
+ ego build -trimpath .
+}
+
+src_test() {
+ go test -work "./..." || die
+}
+
+src_install() {
+ dobin gotestsum
+}