summaryrefslogtreecommitdiff
path: root/dev-go/gopls/gopls-0.18.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-go/gopls/gopls-0.18.0.ebuild')
-rw-r--r--dev-go/gopls/gopls-0.18.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-go/gopls/gopls-0.18.0.ebuild b/dev-go/gopls/gopls-0.18.0.ebuild
new file mode 100644
index 0000000..d263b4e
--- /dev/null
+++ b/dev-go/gopls/gopls-0.18.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2022-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+DESCRIPTION="\"Go please\" is the official Go language server"
+HOMEPAGE="https://github.com/golang/tools/blob/master/gopls/README.md"
+SRC_URI="https://github.com/golang/tools/archive/refs/tags/gopls/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://share.terinstock.com/${P}-vendor.tar.xz "
+S=${WORKDIR}/tools-gopls-v${PV}/${PN}
+
+LICENSE="BSD"
+LICENSE+=" MIT"
+BDEPEND=">=dev-lang/go-1.23.4"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# TODO: fix test failure with deps tarball
+RESTRICT+=" test"
+
+src_compile() {
+ ego build -trimpath -ldflags "-X main.version=${PV}" .
+}
+
+src_test() {
+ go test -work "./..." || die
+}
+
+src_install() {
+ dobin gopls
+ dodoc -r doc README.md
+}