summaryrefslogtreecommitdiff
path: root/app-text/plover/plover-4.0.0_rc2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/plover/plover-4.0.0_rc2-r1.ebuild')
-rw-r--r--app-text/plover/plover-4.0.0_rc2-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-text/plover/plover-4.0.0_rc2-r1.ebuild b/app-text/plover/plover-4.0.0_rc2-r1.ebuild
new file mode 100644
index 0000000..ebeebb9
--- /dev/null
+++ b/app-text/plover/plover-4.0.0_rc2-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10..13} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 desktop pypi
+
+DESCRIPTION="Free and open source real-time stenography engine."
+HOMEPAGE="https://www.openstenoproject.org/plover/"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/pyqt5[${PYTHON_USEDEP}]
+ dev-python/pyserial[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+ dev-python/python-xlib[${PYTHON_USEDEP}]
+ dev-python/rtf-tokenize[${PYTHON_USEDEP}]
+ dev-python/plover-stroke[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ echo "StartupWMClass=org.openstenoproject.python3" >> linux/${PN}.desktop
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ domenu linux/${PN}.desktop
+ doicon plover/assets/${PN}.png
+ newicon plover/assets/${PN}-icon.svg ${PN}.svg
+}