summaryrefslogtreecommitdiff
path: root/app-shells/direnv/direnv-2.34.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/direnv/direnv-2.34.0.ebuild')
-rw-r--r--app-shells/direnv/direnv-2.34.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/app-shells/direnv/direnv-2.34.0.ebuild b/app-shells/direnv/direnv-2.34.0.ebuild
new file mode 100644
index 0000000..7fc9ad3
--- /dev/null
+++ b/app-shells/direnv/direnv-2.34.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Environment variable manager for shell"
+HOMEPAGE="https://github.com/direnv/direnv"
+SRC_URI="https://github.com/direnv/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://share.terinstock.com/${P}-vendor.tar.xz"
+
+LICENSE="MIT"
+LICENSE+=" BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="test" # fails
+
+src_install() {
+ einstalldocs
+ emake DESTDIR="${D}" PREFIX="/usr" install
+}