summaryrefslogtreecommitdiff
path: root/app-misc/gron/gron-0.7.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/gron/gron-0.7.1.ebuild')
-rw-r--r--app-misc/gron/gron-0.7.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-misc/gron/gron-0.7.1.ebuild b/app-misc/gron/gron-0.7.1.ebuild
new file mode 100644
index 0000000..825ce22
--- /dev/null
+++ b/app-misc/gron/gron-0.7.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+DESCRIPTION="Make JSON greppable!"
+HOMEPAGE="https://github.com/tomnomnom/gron"
+BDEPEND=">=dev-lang/go-1.15"
+SRC_URI="https://github.com/tomnomnom/gron/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://share.terinstock.com/${P}-vendor.tar.xz "
+
+LICENSE="MIT"
+LICENSE+=" BSD-2 "
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_compile() {
+ ego build .
+}
+
+src_test() {
+ ego test ./...
+}
+
+src_install() {
+ dobin gron
+}