summaryrefslogtreecommitdiff
path: root/app-containers/oras/oras-1.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-containers/oras/oras-1.2.0.ebuild')
-rw-r--r--app-containers/oras/oras-1.2.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-containers/oras/oras-1.2.0.ebuild b/app-containers/oras/oras-1.2.0.ebuild
new file mode 100644
index 0000000..7dc9bf9
--- /dev/null
+++ b/app-containers/oras/oras-1.2.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+DESCRIPTION="OCI registry client"
+HOMEPAGE="https://github.com/oras-project/oras"
+BDEPEND=">=dev-lang/go-1.22"
+SRC_URI="https://github.com/oras-project/oras/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://share.terinstock.com/${P}-vendor.tar.xz"
+COMMIT="dcef719e208a9b226b15bc6512ad729a7dd93270"
+
+LICENSE="BSD"
+LICENSE+=" Apache-2.0 MIT BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_compile() {
+ ego build -ldflags "-X oras.land/oras/internal/version.BuildMetadata="" \
+ -X oras.land/oras/internal/version.GitCommit=${COMMIT} \
+ -X oras.land/oras/internal/version.GitTreeState=clean" \
+ ./cmd/oras
+}
+
+src_test() {
+ ego test ./...
+}
+
+src_install() {
+ dobin oras
+}