summaryrefslogtreecommitdiff
path: root/sys-fs/zrepl/zrepl-0.6.1.ebuild
diff options
context:
space:
mode:
authorLibravatar Terin Stock <terinjokes@gmail.com>2025-02-16 23:44:16 +0100
committerLibravatar Terin Stock <terinjokes@gmail.com>2025-02-16 23:44:16 +0100
commit135b04b73e52ce3ad79c019db865376b329cc4a0 (patch)
tree2a0b249b13273b6c2c1eb8ee02032f464387336e /sys-fs/zrepl/zrepl-0.6.1.ebuild
parentapp-shells/direnv: add shell-init files (diff)
downloadebuilds-135b04b73e52ce3ad79c019db865376b329cc4a0.tar.xz
sys-fs/zrepl: new package, add 0.6.1
Diffstat (limited to 'sys-fs/zrepl/zrepl-0.6.1.ebuild')
-rw-r--r--sys-fs/zrepl/zrepl-0.6.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-fs/zrepl/zrepl-0.6.1.ebuild b/sys-fs/zrepl/zrepl-0.6.1.ebuild
new file mode 100644
index 0000000..2b71e50
--- /dev/null
+++ b/sys-fs/zrepl/zrepl-0.6.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2020-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module systemd shell-completion
+
+DESCRIPTION="One-stop ZFS backup & replication solution"
+HOMEPAGE="https://zrepl.github.io/"
+BDEPEND=">=dev-lang/go-1.12"
+SRC_URI="https://github.com/zrepl/zrepl/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://share.terinstock.com/${P}-deps.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_compile() {
+ ego build -trimpath .
+
+ ./zrepl gencompletion bash "${PN}.bash" || die
+ ./zrepl gencompletion zsh "${PN}.zsh" || die
+}
+
+src_install() {
+ dobin zrepl
+ einstalldocs
+
+ newbashcomp "${PN}.bash" "${PN}"
+ newzshcomp "${PN}.zsh" "_${PN}"
+
+ sed -i -e 's:/usr/local/bin/zrepl:/usr/bin/zrepl:' dist/systemd/zrepl.service || die
+ systemd_dounit dist/systemd/zrepl.service
+}