summaryrefslogtreecommitdiff
path: root/sys-auth/yubikey-agent/yubikey-agent-0.1.6.ebuild
diff options
context:
space:
mode:
authorLibravatar Terin Stock <terinjokes@gmail.com>2024-09-02 20:12:24 +0200
committerLibravatar Terin Stock <terinjokes@gmail.com>2024-09-02 20:30:50 +0200
commitf4517ed32adde7c7c1d075a7551fa9712c9b81d8 (patch)
treeda4e6fbc588053a3be2ac6cbb7393213424ac7cc /sys-auth/yubikey-agent/yubikey-agent-0.1.6.ebuild
parentapp-containers/oras: new package, add 1.2.0 (diff)
downloadebuilds-f4517ed32adde7c7c1d075a7551fa9712c9b81d8.tar.xz
sys-auth/yubikey-agent: new package, add 0.1.6
Diffstat (limited to 'sys-auth/yubikey-agent/yubikey-agent-0.1.6.ebuild')
-rw-r--r--sys-auth/yubikey-agent/yubikey-agent-0.1.6.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-auth/yubikey-agent/yubikey-agent-0.1.6.ebuild b/sys-auth/yubikey-agent/yubikey-agent-0.1.6.ebuild
new file mode 100644
index 0000000..980d796
--- /dev/null
+++ b/sys-auth/yubikey-agent/yubikey-agent-0.1.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module systemd
+
+DESCRIPTION="A a seamless ssh-agent for YubiKeys"
+HOMEPAGE="https://github.com/FiloSottile/yubikey-agent"
+BDEPEND=">=dev-lang/go-1.19"
+DEPEND="sys-apps/pcsc-lite"
+RDEPEND="sys-apps/pcsc-lite"
+SRC_URI="https://github.com/FiloSottile/yubikey-agent/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://share.terinstock.com/${P}-vendor.tar.xz"
+
+LICENSE="BSD"
+LICENSE+=" Apache-2.0 MIT"
+SLOT="0"
+KEYWORDS="amd64"
+
+src_compile() {
+ ego build .
+}
+
+src_test() {
+ ego test -v ./...
+}
+
+src_install() {
+ dosbin yubikey-agent
+ systemd_douserunit contrib/systemd/user/yubikey-agent.service
+}