summaryrefslogtreecommitdiff
path: root/dev-python/rtf-tokenize/rtf-tokenize-1.0.0.ebuild
diff options
context:
space:
mode:
authorLibravatar Terin Stock <terinjokes@gmail.com>2024-09-22 21:54:20 +0200
committerLibravatar Terin Stock <terinjokes@gmail.com>2024-09-22 22:40:46 +0200
commitab7140cdc72e608a5fd00a8f9fb39ad1995f27d0 (patch)
tree28548f73c33f944f17783905fb7e6aeb4eeef0d6 /dev-python/rtf-tokenize/rtf-tokenize-1.0.0.ebuild
parentdev-python/plover-uinput: new package, add 0.0.15 (diff)
downloadebuilds-ab7140cdc72e608a5fd00a8f9fb39ad1995f27d0.tar.xz
dev-python/rtf-tokenize: new package, add 1.0.0
Diffstat (limited to 'dev-python/rtf-tokenize/rtf-tokenize-1.0.0.ebuild')
-rw-r--r--dev-python/rtf-tokenize/rtf-tokenize-1.0.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/rtf-tokenize/rtf-tokenize-1.0.0.ebuild b/dev-python/rtf-tokenize/rtf-tokenize-1.0.0.ebuild
new file mode 100644
index 0000000..c78f022
--- /dev/null
+++ b/dev-python/rtf-tokenize/rtf-tokenize-1.0.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Simple RTF tokenizer package for Python"
+HOMEPAGE="https://github.com/openstenoproject/rtf_tokenize"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+python_test() {
+ "${EPYTHON}" test/test_tokenizer.py -v || die "Tests fail with ${EPYTHON}"
+}