summaryrefslogtreecommitdiff
path: root/dev-python/plover-stitching/plover-stitching-0.1.0.ebuild
diff options
context:
space:
mode:
authorLibravatar Terin Stock <terinjokes@gmail.com>2024-09-24 01:10:47 +0200
committerLibravatar Terin Stock <terinjokes@gmail.com>2024-09-24 01:10:47 +0200
commit45421c2c88364205a940dac9e67ac90bfd8f1053 (patch)
treefe45032b43bedaf6193c3054548ba1eae83a0cb5 /dev-python/plover-stitching/plover-stitching-0.1.0.ebuild
parentdev-python/plover-python-dictionary: new package, add 1.1.0 (diff)
downloadebuilds-45421c2c88364205a940dac9e67ac90bfd8f1053.tar.xz
dev-python/plover-stitching: new package, add 0.1.0
Diffstat (limited to 'dev-python/plover-stitching/plover-stitching-0.1.0.ebuild')
-rw-r--r--dev-python/plover-stitching/plover-stitching-0.1.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/plover-stitching/plover-stitching-0.1.0.ebuild b/dev-python/plover-stitching/plover-stitching-0.1.0.ebuild
new file mode 100644
index 0000000..f65c20a
--- /dev/null
+++ b/dev-python/plover-stitching/plover-stitching-0.1.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Stitch words like T-H-I-S using Plover strokes"
+HOMEPAGE="https://github.com/morinted/plover_stitching"
+
+RDEPENDS="
+ app-text/plover[${PYTHON_USEDEP}]
+"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest