summaryrefslogtreecommitdiff
path: root/dev-python/plover-lapwing-aio/plover-lapwing-aio-1.3.1.ebuild
diff options
context:
space:
mode:
authorLibravatar Terin Stock <terinjokes@gmail.com>2024-09-24 01:10:52 +0200
committerLibravatar Terin Stock <terinjokes@gmail.com>2024-09-24 01:10:52 +0200
commit8b64b0293567d615cfea5661d3181d7285b125aa (patch)
treeca77f1487d76fa70372664363a4bdce317517e77 /dev-python/plover-lapwing-aio/plover-lapwing-aio-1.3.1.ebuild
parentdev-python/plover-stitching: new package, add 0.1.0 (diff)
downloadebuilds-8b64b0293567d615cfea5661d3181d7285b125aa.tar.xz
dev-python/plover-lapwing-aio: new package, add 1.3.1
Diffstat (limited to 'dev-python/plover-lapwing-aio/plover-lapwing-aio-1.3.1.ebuild')
-rw-r--r--dev-python/plover-lapwing-aio/plover-lapwing-aio-1.3.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/plover-lapwing-aio/plover-lapwing-aio-1.3.1.ebuild b/dev-python/plover-lapwing-aio/plover-lapwing-aio-1.3.1.ebuild
new file mode 100644
index 0000000..c9e8bb4
--- /dev/null
+++ b/dev-python/plover-lapwing-aio/plover-lapwing-aio-1.3.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Plover plugin to install Lapwing dependencies and extras."
+HOMEPAGE="https://github.com/aerickt/plover-lapwing-aio"
+
+RDEPEND="
+ app-text/plover[${PYTHON_USEDEP}]
+ dev-python/plover-dict-commands[${PYTHON_USEDEP}]
+ dev-python/plover-last-translation[${PYTHON_USEDEP}]
+ dev-python/plover-modal-dictionary[${PYTHON_USEDEP}]
+ dev-python/plover-python-dictionary[${PYTHON_USEDEP}]
+ dev-python/plover-stitching[${PYTHON_USEDEP}]
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"