summaryrefslogtreecommitdiff
path: root/dev-go/staticcheck/staticcheck-2024.1.1.ebuild
diff options
context:
space:
mode:
authorLibravatar Terin Stock <terinjokes@gmail.com>2024-09-28 14:29:23 -0500
committerLibravatar Terin Stock <terinjokes@gmail.com>2024-09-28 14:29:23 -0500
commitc2486d0dccbdada23c8b1a067ec03c2002e2e26d (patch)
tree2a970afa09fc81f8a94e5f6c61f4212756fe1207 /dev-go/staticcheck/staticcheck-2024.1.1.ebuild
parentdev-vcs/ghq: new package, add 1.6.2 (diff)
downloadebuilds-c2486d0dccbdada23c8b1a067ec03c2002e2e26d.tar.xz
dev-go/staticcheck: fix manifest hashes
Diffstat (limited to 'dev-go/staticcheck/staticcheck-2024.1.1.ebuild')
-rw-r--r--dev-go/staticcheck/staticcheck-2024.1.1.ebuild30
1 files changed, 0 insertions, 30 deletions
diff --git a/dev-go/staticcheck/staticcheck-2024.1.1.ebuild b/dev-go/staticcheck/staticcheck-2024.1.1.ebuild
deleted file mode 100644
index 7b21fad..0000000
--- a/dev-go/staticcheck/staticcheck-2024.1.1.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 2022-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-inherit go-module
-
-DESCRIPTION="The advanced Go linter"
-HOMEPAGE="https://staticcheck.io/"
-BDEPEND=">=dev-lang/go-1.15"
-SRC_URI="https://github.com/dominikh/go-tools/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
-SRC_URI+=" https://share.terinstock.com/${P}-vendor.tar.xz "
-S="${WORKDIR}/go-tools-${PV}"
-
-LICENSE="MIT"
-LICENSE+=" BSD "
-SLOT="0"
-KEYWORDS="~amd64"
-
-src_compile() {
- mkdir bin || die
- ego build -o bin/staticcheck ./cmd/staticcheck
-}
-
-src_test() {
- ego test ./...
-}
-
-src_install() {
- dobin bin/staticcheck
-}