summaryrefslogtreecommitdiff
path: root/dev-go/staticcheck/staticcheck-2024.1.1.ebuild
diff options
context:
space:
mode:
authorLibravatar Terin Stock <terinjokes@gmail.com>2024-09-15 22:03:25 +0000
committerLibravatar Terin Stock <terinjokes@gmail.com>2024-09-15 22:03:25 +0000
commitaa497def22827a871a88c2efe89bfb1427d38a80 (patch)
tree3370b17f969d918cd3a7d95d1067071f6b232100 /dev-go/staticcheck/staticcheck-2024.1.1.ebuild
parentapp-misc/gron: new package, add 0.7.1 (diff)
downloadebuilds-aa497def22827a871a88c2efe89bfb1427d38a80.tar.xz
dev-go/staticcheck: new package, add 2024.1.1
Diffstat (limited to 'dev-go/staticcheck/staticcheck-2024.1.1.ebuild')
-rw-r--r--dev-go/staticcheck/staticcheck-2024.1.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-go/staticcheck/staticcheck-2024.1.1.ebuild b/dev-go/staticcheck/staticcheck-2024.1.1.ebuild
new file mode 100644
index 0000000..7b21fad
--- /dev/null
+++ b/dev-go/staticcheck/staticcheck-2024.1.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+DESCRIPTION="The advanced Go linter"
+HOMEPAGE="https://staticcheck.io/"
+BDEPEND=">=dev-lang/go-1.15"
+SRC_URI="https://github.com/dominikh/go-tools/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://share.terinstock.com/${P}-vendor.tar.xz "
+S="${WORKDIR}/go-tools-${PV}"
+
+LICENSE="MIT"
+LICENSE+=" BSD "
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_compile() {
+ mkdir bin || die
+ ego build -o bin/staticcheck ./cmd/staticcheck
+}
+
+src_test() {
+ ego test ./...
+}
+
+src_install() {
+ dobin bin/staticcheck
+}