summaryrefslogtreecommitdiff
path: root/app-text/plover/plover-4.0.0_rc2.ebuild
diff options
context:
space:
mode:
authorLibravatar Terin Stock <terinjokes@gmail.com>2024-09-22 21:59:10 +0200
committerLibravatar Terin Stock <terinjokes@gmail.com>2024-09-22 22:40:46 +0200
commit2162e7e7dccefd24b322f4c7eba8cd3020d495bc (patch)
tree294312c08fa4498ee1a021bd1382477502b921f0 /app-text/plover/plover-4.0.0_rc2.ebuild
parentdev-python/rtf-tokenize: new package, add 1.0.0 (diff)
downloadebuilds-2162e7e7dccefd24b322f4c7eba8cd3020d495bc.tar.xz
app-text/plover: new package, add 4.0.0_rc2
Diffstat (limited to 'app-text/plover/plover-4.0.0_rc2.ebuild')
-rw-r--r--app-text/plover/plover-4.0.0_rc2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-text/plover/plover-4.0.0_rc2.ebuild b/app-text/plover/plover-4.0.0_rc2.ebuild
new file mode 100644
index 0000000..df6e9cf
--- /dev/null
+++ b/app-text/plover/plover-4.0.0_rc2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10..13} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 desktop pypi
+
+DESCRIPTION="Free and open source real-time stenography engine."
+HOMEPAGE="https://www.openstenoproject.org/plover/"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/PyQt5[${PYTHON_USEDEP}]
+ dev-python/pyserial[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+ dev-python/python-xlib[${PYTHON_USEDEP}]
+ dev-python/rtf-tokenize[${PYTHON_USEDEP}]
+ dev-python/plover-stroke[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ echo "StartupWMClass=org.openstenoproject.python3" >> linux/${PN}.desktop
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ domenu linux/${PN}.desktop
+ doicon plover/assets/${PN}.png
+ newicon plover/assets/${PN}-icon.svg ${PN}.svg
+}