summaryrefslogtreecommitdiff
path: root/app-crypt/lego/lego-4.21.0.ebuild
diff options
context:
space:
mode:
authorLibravatar Terin Stock <terinjokes@gmail.com>2024-12-23 00:45:12 +0000
committerLibravatar Terin Stock <terinjokes@gmail.com>2024-12-23 00:45:12 +0000
commit68638c04d2ef703cdc04681a5612844ecd3201d6 (patch)
tree6369720dadb7d67acb654238cdfe66c540fec10c /app-crypt/lego/lego-4.21.0.ebuild
parentnet-misc/obligator: add 0.3.0_p20241212, drop 0.3.0_p20240910-r1 (diff)
downloadebuilds-68638c04d2ef703cdc04681a5612844ecd3201d6.tar.xz
app-crypt/lego: add 4.21.0, drop 4.19.2
Diffstat (limited to 'app-crypt/lego/lego-4.21.0.ebuild')
-rw-r--r--app-crypt/lego/lego-4.21.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-crypt/lego/lego-4.21.0.ebuild b/app-crypt/lego/lego-4.21.0.ebuild
new file mode 100644
index 0000000..87c9e85
--- /dev/null
+++ b/app-crypt/lego/lego-4.21.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+DESCRIPTION="Let's Encrypt/ACME client and library written in Go "
+HOMEPAGE="https://github.com/go-acme/lego"
+BDEPEND=">=dev-lang/go-1.22.0"
+SRC_URI="https://github.com/go-acme/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://share.terinstock.com/${P}-vendor.tar.xz"
+
+LICENSE="MIT"
+LICENSE+=" Apache-2.0 BSD MPL-2.0 BSD-2 "
+SLOT="0"
+KEYWORDS="~amd64"
+
+# tests require reaching out to DNS servers
+PROPERTIES="test_network"
+RESTRICT="test"
+
+src_compile() {
+ mkdir bin || die
+ ego build -trimpath --ldflags "-X main.version=${PV}" -o bin/lego ./cmd/lego/...
+}
+
+src_test() {
+ ego test ./...
+}
+
+src_install() {
+ dobin bin/lego
+}