summaryrefslogtreecommitdiff
path: root/app-crypt/lego/lego-4.19.2.ebuild
diff options
context:
space:
mode:
authorLibravatar Terin Stock <terinjokes@gmail.com>2024-10-19 16:49:23 +0200
committerLibravatar Terin Stock <terinjokes@gmail.com>2024-10-19 16:49:23 +0200
commit76e1fb8f9057cada70acf6deaed0a1f819674b73 (patch)
tree8d14307209b83468800bacb17cc4f35e0dd02e66 /app-crypt/lego/lego-4.19.2.ebuild
parentnet-proxy/traefik: new package, add 3.1.6 (diff)
downloadebuilds-76e1fb8f9057cada70acf6deaed0a1f819674b73.tar.xz
app-crypt/lego: new package, add 4.19.2
Diffstat (limited to 'app-crypt/lego/lego-4.19.2.ebuild')
-rw-r--r--app-crypt/lego/lego-4.19.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-crypt/lego/lego-4.19.2.ebuild b/app-crypt/lego/lego-4.19.2.ebuild
new file mode 100644
index 0000000..87c9e85
--- /dev/null
+++ b/app-crypt/lego/lego-4.19.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+DESCRIPTION="Let's Encrypt/ACME client and library written in Go "
+HOMEPAGE="https://github.com/go-acme/lego"
+BDEPEND=">=dev-lang/go-1.22.0"
+SRC_URI="https://github.com/go-acme/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://share.terinstock.com/${P}-vendor.tar.xz"
+
+LICENSE="MIT"
+LICENSE+=" Apache-2.0 BSD MPL-2.0 BSD-2 "
+SLOT="0"
+KEYWORDS="~amd64"
+
+# tests require reaching out to DNS servers
+PROPERTIES="test_network"
+RESTRICT="test"
+
+src_compile() {
+ mkdir bin || die
+ ego build -trimpath --ldflags "-X main.version=${PV}" -o bin/lego ./cmd/lego/...
+}
+
+src_test() {
+ ego test ./...
+}
+
+src_install() {
+ dobin bin/lego
+}