summaryrefslogtreecommitdiff
path: root/contrib/buildsystems/CMakeLists.txt
diff options
context:
space:
mode:
authorLibravatar Junio C Hamano <gitster@pobox.com>2021-12-08 13:16:32 -0800
committerLibravatar Junio C Hamano <gitster@pobox.com>2021-12-08 13:16:32 -0800
commite95566d9095ae93abe59360b22a103767e2da23c (patch)
treee369832a2896af657536a8a48c652a7315916fb6 /contrib/buildsystems/CMakeLists.txt
parentThe first batch to start the current cycle (diff)
parentgit-compat-util: add a test balloon for C99 support (diff)
downloadtgif-e95566d9095ae93abe59360b22a103767e2da23c.tar.xz
Merge branch 'bc/require-c99' into jk/limit-developers-to-gnu99
* bc/require-c99: git-compat-util: add a test balloon for C99 support
Diffstat (limited to 'contrib/buildsystems/CMakeLists.txt')
-rw-r--r--contrib/buildsystems/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/contrib/buildsystems/CMakeLists.txt b/contrib/buildsystems/CMakeLists.txt
index 86b4611446..be67b4dab0 100644
--- a/contrib/buildsystems/CMakeLists.txt
+++ b/contrib/buildsystems/CMakeLists.txt
@@ -208,7 +208,7 @@ endif()
if(CMAKE_C_COMPILER_ID STREQUAL "MSVC")
set(CMAKE_RUNTIME_OUTPUT_DIRECTORY_DEBUG ${CMAKE_BINARY_DIR})
set(CMAKE_RUNTIME_OUTPUT_DIRECTORY_RELEASE ${CMAKE_BINARY_DIR})
- add_compile_options(/MP)
+ add_compile_options(/MP /std:c11)
endif()
#default behaviour