# Copyright 2020-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8
inherit go-module

DESCRIPTION="HTTPD for CGit"
HOMEPAGE="https://git.terinstock.com/cgit-httpd.git/about/"
BDEPEND=">=dev-lang/go-1.18"
SRC_URI="https://git.terinstock.com/cgit-httpd.git/snapshot/${P}.tar.xz"
SRC_URI+=" https://share.terinstock.com/${P}-vendor.tar.xz"

LICENSE="MPL-2.0"
LICENSE+=" BSD"
SLOT="0"
KEYWORDS="~amd64"

src_compile() {
	ego build .
}

src_test() {
	ego test ./...
}

src_install() {
	dobin cgit-httpd
}