# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8
inherit linux-mod-r1 udev

DESCRIPTION="Virtual serial port kernel module"
HOMEPAGE="https://github.com/anszom/vtty"
COMMIT="7ab72cec2dbb59f0963d55f27cbc57025fc6f579"
SRC_URI="https://github.com/anszom/vtty/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${PN}-${COMMIT}"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64"

RDEPEND="virtual/udev"
DEPEND="${RDEPEND}"

src_compile() {
	local modlist=( vtty )
	local modargs=( KDIR="${KV_OUT_DIR}" )

	linux-mod-r1_src_compile
}

src_install() {
	linux-mod-r1_src_install

	udev_newrules - 69-vtty.rules <<-EOF
		# do not edit this file, it will be overwritten on update
		#
		KERNEL=="vtmx", SUBSYSTEM=="misc", TAG+="uaccess"
		KERNEL=="ttyV[0-9]*", SUBSYSTEM=="tty", TAG+="uaccess"
	EOF
}

pkg_postinst() {
	linux-mod-r1_pkg_postinst
	udev_reload
}

pkg_postrm() {
	udev_reload
}