# Copyright 2020-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8
inherit go-module systemd

DESCRIPTION="A a seamless ssh-agent for YubiKeys"
HOMEPAGE="https://github.com/FiloSottile/yubikey-agent"
BDEPEND=">=dev-lang/go-1.19"
DEPEND="sys-apps/pcsc-lite"
RDEPEND="sys-apps/pcsc-lite"
SRC_URI="https://github.com/FiloSottile/yubikey-agent/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
SRC_URI+=" https://share.terinstock.com/${P}-vendor.tar.xz"

LICENSE="BSD"
LICENSE+=" Apache-2.0 MIT"
SLOT="0"
KEYWORDS="amd64"

src_compile() {
	ego build .
}

src_test() {
	ego test -v ./...
}

src_install() {
	dosbin yubikey-agent
	systemd_douserunit contrib/systemd/user/yubikey-agent.service
}