# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8
inherit go-module

DESCRIPTION="Remote repository management made easy"
HOMEPAGE="https://github.com/x-motemen/ghq"
BDEPEND=">=dev-lang/go-1.22.5"
SRC_URI="https://github.com/x-motemen/ghq/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
SRC_URI+=" https://share.terinstock.com/${P}-vendor.tar.xz"

LICENSE="MIT"
LICENSE+=" BSD-2 BSD"
SLOT="0"
KEYWORDS="~amd64"

src_compile() {
	ego build .
}

src_test() {
	ego test ./...
}

src_install() {
	dobin ghq
}