# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..13} )

inherit distutils-r1 pypi

DESCRIPTION="Plover output plugin for linux using evdev / uinput"
HOMEPAGE="https://github.com/LilleAila/plover-uinput"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"

RDEPEND="
	dev-python/evdev[${PYTHON_USEDEP}]
	dev-python/xkbcommon[${PYTHON_USEDEP}]
"

src_prepare() {
	# unpin xkbcommon
	sed -i -e 's:xkbcommon<1.1:xkbcommon:' setup.cfg || die
	distutils-r1_src_prepare
}