# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit go-module

DESCRIPTION="Environment variable manager for shell"
HOMEPAGE="https://github.com/direnv/direnv"
SRC_URI="https://github.com/direnv/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
SRC_URI+=" https://share.terinstock.com/${P}-vendor.tar.xz"

LICENSE="MIT"
LICENSE+=" BSD"
SLOT="0"
KEYWORDS="~amd64"
RESTRICT="test" # fails

src_install() {
	einstalldocs
	emake DESTDIR="${ED}" PREFIX="/usr" install
}