# Copyright 2020-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8
inherit go-module

DESCRIPTION="A Docker credential helper for GCR users"
HOMEPAGE="https://github.com/GoogleCloudPlatform/docker-credential-gcr"
BDEPEND=">=dev-lang/go-1.21"
SRC_URI="https://github.com/GoogleCloudPlatform/docker-credential-gcr/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
SRC_URI+=" https://share.terinstock.com/${P}-vendor.tar.xz "

LICENSE="Apache-2.0"
LICENSE+=" MIT BSD-2 BSD "
SLOT="0"
KEYWORDS="~amd64"

src_compile() {
	ego build \
		-ldflags="-X github.com/GoogleCloudPlatform/docker-credential-gcr/v2/config.Version=${PV}" \
		.
}

src_install() {
	dobin docker-credential-gcr
}