summaryrefslogtreecommitdiff
path: root/sys-auth/kubectl-passman/kubectl-passman-1.2.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth/kubectl-passman/kubectl-passman-1.2.3.ebuild')
-rw-r--r--sys-auth/kubectl-passman/kubectl-passman-1.2.3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-auth/kubectl-passman/kubectl-passman-1.2.3.ebuild b/sys-auth/kubectl-passman/kubectl-passman-1.2.3.ebuild
new file mode 100644
index 0000000..b412c81
--- /dev/null
+++ b/sys-auth/kubectl-passman/kubectl-passman-1.2.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+DESCRIPTION="The missing link/glue between common password managers and kubectl"
+HOMEPAGE="https://github.com/chrisns/kubectl-passman"
+BDEPEND=">=dev-lang/go-1.12"
+SRC_URI="https://github.com/chrisns/kubectl-passman/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://share.terinstock.com/${P}-deps.tar.xz "
+
+LICENSE="MIT"
+LICENSE+=" BSD-2 "
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_compile() {
+ ego build -ldflags "-X main.VERSION=${PV}" .
+}
+
+src_test() {
+ ego test ./...
+}
+
+src_install() {
+ dosbin kubectl-passman
+}