summaryrefslogtreecommitdiff
path: root/dev-vcs/git-branchless/git-branchless-0.10.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/git-branchless/git-branchless-0.10.0.ebuild')
-rw-r--r--dev-vcs/git-branchless/git-branchless-0.10.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-vcs/git-branchless/git-branchless-0.10.0.ebuild b/dev-vcs/git-branchless/git-branchless-0.10.0.ebuild
new file mode 100644
index 0000000..fa2b7da
--- /dev/null
+++ b/dev-vcs/git-branchless/git-branchless-0.10.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CRATES=" "
+inherit cargo
+
+DESCRIPTION="Branchless workflow for Git"
+HOMEPAGE="https://github.com/arxanas/git-branchless"
+SRC_URI="https://github.com/arxanas/git-branchless/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://share.terinstock.com/${P}-vendor.tar.xz "
+
+LICENSE="|| ( MIT Apache-2.0 )"
+LICENSE+=" MIT Apache-2.0 Unicode-DFS-2016 0BSD Apache-2.0-with-LLVM-exceptions"
+LICENSE+=" BSD-2 BSD ISC Unlicense MPL-2.0 CC0-1.0 Boost-1.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ cargo_src_unpack
+ mkdir "${S}"/{vendor,.cargo} || die
+ ln -s "${WORKDIR}/vendor/"* "${S}"/vendor || die
+ cp "${FILESDIR}"/"${PN}-vendor-config" "${S}/.cargo/config.toml" || die
+}
+
+src_configure() {
+ cargo_gen_config
+ cargo_src_configure --no-default-features --bin git-branchless
+}
+
+src_install() {
+ cargo_src_install --path ./git-branchless
+}
+
+QA_FLAGS_IGNORED="usr/bin/${PN}"