summaryrefslogtreecommitdiff
path: root/app-containers/docker-credential-gcr/docker-credential-gcr-2.1.25.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-containers/docker-credential-gcr/docker-credential-gcr-2.1.25.ebuild')
-rw-r--r--app-containers/docker-credential-gcr/docker-credential-gcr-2.1.25.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-containers/docker-credential-gcr/docker-credential-gcr-2.1.25.ebuild b/app-containers/docker-credential-gcr/docker-credential-gcr-2.1.25.ebuild
new file mode 100644
index 0000000..fc9734e
--- /dev/null
+++ b/app-containers/docker-credential-gcr/docker-credential-gcr-2.1.25.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+DESCRIPTION="A Docker credential helper for GCR users"
+HOMEPAGE="https://github.com/GoogleCloudPlatform/docker-credential-gcr"
+BDEPEND=">=dev-lang/go-1.21"
+SRC_URI="https://github.com/GoogleCloudPlatform/docker-credential-gcr/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://share.terinstock.com/${P}-vendor.tar.xz "
+
+LICENSE="Apache-2.0"
+LICENSE+=" MIT BSD-2 BSD "
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_compile() {
+ ego build \
+ -ldflags="-X github.com/GoogleCloudPlatform/docker-credential-gcr/v2/config.Version=${PV}" \
+ .
+}
+
+src_install() {
+ dobin docker-credential-gcr
+}